Degraded performance in EU region

Incident Report for Bettermode

Resolved

The issues with the performance have been resolved.
Posted Oct 21, 2025 - 19:12 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 19:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 19:04 UTC

Monitoring

The implemented fix has remediated the issue with analytics. We are still closely monitoring the situation.
Posted Oct 21, 2025 - 18:51 UTC

Identified

We have been able to identify an issue affecting customers within the EU region. It is limited to analytics and page views specifically. A patch has been deployed and we are monitoring the situation. No loss of data has been reported and the analytic results will show up with a delay.
Posted Oct 21, 2025 - 17:50 UTC
This incident affected: Community - Europe (Analytics & Audit Logs).