Issue around community service
Incident Report for Bettermode
Resolved
The US region community services experienced technical difficulties today from 19:34 UTC to 19:49. We have resolved the issue and all services are up now.
Posted Dec 19, 2023 - 21:18 UTC
This incident affected: Community - North America (Community Service).