We have identified an issue around our community service
Incident Report for Bettermode
Resolved
We've resolved the issue regarding community service. Everything is back up.
Posted Mar 12, 2023 - 12:28 UTC
Investigating
The community service is experiencing technical difficulties. Our tech team is notified.
Posted Mar 12, 2023 - 12:27 UTC
This incident affected: Community - Europe (Community Service) and Community - North America (Community Service).