Communities in US region are down.

Incident Report for Bettermode

Resolved

The incident has been resolved.
Posted Jun 14, 2021 - 17:30 UTC

Monitoring

Systems are back up. We're monitoring our servers to make sure everything is working properly.
Posted Jun 14, 2021 - 17:22 UTC

Identified

We have identified the issue and are working on a fix.
Posted Jun 14, 2021 - 17:19 UTC